Commit 2cf93262 authored by Petr Vorel's avatar Petr Vorel Committed by carbon

package/busybox: bump version to 1.34.0

* backport fix from 1_34_stable branch
* refresh patches
Signed-off-by: default avatarPetr Vorel <petr.vorel@gmail.com>
Signed-off-by: default avatarArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
parent a452770d
From d4fec31889ad660a58dab633c511221feb66e817 Mon Sep 17 00:00:00 2001 From 60da1d0763224698008d847eb8ad8d4d8c6f54ff Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Sat, 5 Oct 2013 15:55:06 +0200 Date: Sat, 5 Oct 2013 15:55:06 +0200
Subject: [PATCH] networking/libiproute: use <linux/if_packet.h> instead of Subject: [PATCH] networking/libiproute: use <linux/if_packet.h> instead of
...@@ -14,10 +14,15 @@ This commit fixes the build of iplink with the musl C library. ...@@ -14,10 +14,15 @@ This commit fixes the build of iplink with the musl C library.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
[Gustavo: update for busybox 1.22.0] [Gustavo: update for busybox 1.22.0]
Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
---
networking/libiproute/iplink.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff -Nura busybox-1.22.0.orig/networking/libiproute/iplink.c busybox-1.22.0/networking/libiproute/iplink.c diff --git a/networking/libiproute/iplink.c b/networking/libiproute/iplink.c
--- busybox-1.22.0.orig/networking/libiproute/iplink.c 2014-01-01 09:42:40.301137882 -0300 index 1a1064bdc..a4c3ad307 100644
+++ busybox-1.22.0/networking/libiproute/iplink.c 2014-01-01 09:43:01.282827700 -0300 --- a/networking/libiproute/iplink.c
+++ b/networking/libiproute/iplink.c
@@ -7,7 +7,7 @@ @@ -7,7 +7,7 @@
*/ */
#include <net/if.h> #include <net/if.h>
...@@ -25,5 +30,8 @@ diff -Nura busybox-1.22.0.orig/networking/libiproute/iplink.c busybox-1.22.0/net ...@@ -25,5 +30,8 @@ diff -Nura busybox-1.22.0.orig/networking/libiproute/iplink.c busybox-1.22.0/net
-#include <netpacket/packet.h> -#include <netpacket/packet.h>
+#include <linux/if_packet.h> +#include <linux/if_packet.h>
#include <netinet/if_ether.h> #include <netinet/if_ether.h>
#include <linux/if_vlan.h> #include <linux/if_vlan.h>
--
2.33.0
From 67eb23d2be8aba3c474dac81a15b0fa11e5847b7 Mon Sep 17 00:00:00 2001 From 59daea82e7b5abcdb42a4f97a0109f14d5a774ea Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Mon, 25 Nov 2013 22:51:53 +0100 Date: Mon, 25 Nov 2013 22:51:53 +0100
Subject: [PATCH] Makefile.flags: strip non -l arguments returned by pkg-config Subject: [PATCH] Makefile.flags: strip non -l arguments returned by
pkg-config
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
[yann.morin.1998@free.fr: refresh for 1.29.0] [yann.morin.1998@free.fr: refresh for 1.29.0]
...@@ -13,10 +14,10 @@ Signed-off-by: Petr Vorel <petr.vorel@gmail.com> ...@@ -13,10 +14,10 @@ Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
1 file changed, 3 insertions(+), 1 deletion(-) 1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/Makefile.flags b/Makefile.flags diff --git a/Makefile.flags b/Makefile.flags
index 307afa7..885e323 100644 index 667481983..88d76efec 100644
--- a/Makefile.flags --- a/Makefile.flags
+++ b/Makefile.flags +++ b/Makefile.flags
@@ -176,7 +176,9 @@ ifeq ($(CONFIG_SELINUX),y) @@ -180,7 +180,9 @@ ifeq ($(CONFIG_SELINUX),y)
SELINUX_PC_MODULES = libselinux libsepol SELINUX_PC_MODULES = libselinux libsepol
$(eval $(call pkg_check_modules,SELINUX,$(SELINUX_PC_MODULES))) $(eval $(call pkg_check_modules,SELINUX,$(SELINUX_PC_MODULES)))
CPPFLAGS += $(SELINUX_CFLAGS) CPPFLAGS += $(SELINUX_CFLAGS)
...@@ -25,8 +26,8 @@ index 307afa7..885e323 100644 ...@@ -25,8 +26,8 @@ index 307afa7..885e323 100644
+ $(patsubst -l%,%,$(filter -l%,$(SELINUX_LIBS))),\ + $(patsubst -l%,%,$(filter -l%,$(SELINUX_LIBS))),\
+ $(SELINUX_PC_MODULES:lib%=%)) + $(SELINUX_PC_MODULES:lib%=%))
endif endif
ifeq ($(CONFIG_FEATURE_NSLOOKUP_BIG),y) ifeq ($(CONFIG_FEATURE_NSLOOKUP_BIG),y)
-- --
1.8.1.2 2.33.0
From 56824284b749e5b9d568b75d5c5bc471b1814d46 Mon Sep 17 00:00:00 2001
From: Denys Vlasenko <vda.linux@googlemail.com>
Date: Fri, 20 Aug 2021 13:33:50 +0200
Subject: [PATCH] udhcp: fix build breakage on MIPS
Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
---
upstream status: 00adcdb64 ("udhcp: fix build breakage on MIPS")
networking/udhcp/common.h | 12 ------------
1 file changed, 12 deletions(-)
diff --git a/networking/udhcp/common.h b/networking/udhcp/common.h
index 8c678dd32..ca778dab8 100644
--- a/networking/udhcp/common.h
+++ b/networking/udhcp/common.h
@@ -304,18 +304,6 @@ void udhcp_dump_packet(struct dhcp_packet *packet) FAST_FUNC;
# define log3s(msg) ((void)0)
#endif
-#if defined(__mips__)
-/*
- * The 'simple' message functions have a negative impact on the size of the
- * DHCP code when compiled for MIPS, so don't use them in this case.
- */
-#define bb_simple_info_msg bb_info_msg
-#define bb_simple_error_msg bb_error_msg
-#define bb_simple_perror_msg_and_die bb_perror_msg_and_die
-#undef log1s
-#define log1s log1
-#endif
-
/*** Other shared functions ***/
/* 2nd param is "uint32_t*" */
--
2.33.0
# From https://busybox.net/downloads/busybox-1.33.1.tar.bz2.sha256 # From https://busybox.net/downloads/busybox-1.34.0.tar.bz2.sha256
sha256 12cec6bd2b16d8a9446dd16130f2b92982f1819f6e1c5f5887b6db03f5660d28 busybox-1.33.1.tar.bz2 sha256 ec8d1615edb045b83b81966604759c4d4ac921434ab4011da604f629c06074ce busybox-1.34.0.tar.bz2
# Locally computed # Locally computed
sha256 bbfc9843646d483c334664f651c208b9839626891d8f17604db2146962f43548 LICENSE sha256 bbfc9843646d483c334664f651c208b9839626891d8f17604db2146962f43548 LICENSE
sha256 b5a136ed67798e51fe2e0ca0b2a21cb01b904ff0c9f7d563a6292e276607e58f archival/libarchive/bz/LICENSE sha256 b5a136ed67798e51fe2e0ca0b2a21cb01b904ff0c9f7d563a6292e276607e58f archival/libarchive/bz/LICENSE
...@@ -4,7 +4,7 @@ ...@@ -4,7 +4,7 @@
# #
################################################################################ ################################################################################
BUSYBOX_VERSION = 1.33.1 BUSYBOX_VERSION = 1.34.0
BUSYBOX_SITE = https://www.busybox.net/downloads BUSYBOX_SITE = https://www.busybox.net/downloads
BUSYBOX_SOURCE = busybox-$(BUSYBOX_VERSION).tar.bz2 BUSYBOX_SOURCE = busybox-$(BUSYBOX_VERSION).tar.bz2
BUSYBOX_LICENSE = GPL-2.0, bzip2-1.0.4 BUSYBOX_LICENSE = GPL-2.0, bzip2-1.0.4
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment